Server load causing inconsistent behavior in some services

Incident Report for Rise ai Status Page

Resolved

This incident has been resolved.
Posted Sep 07, 2025 - 17:04 UTC

Identified

We are getting reports of inconsistencies in different services sue to unexpected load in our servers.

We are investigating the impact and will continue updating as more information comes up.
Posted Sep 07, 2025 - 16:03 UTC
This incident affected: Dashboard and Gift Cards.