Gift cards not created on some stores

Incident Report for Rise ai Status Page

Resolved

We were able to resolve the issue and gift cards are now created as expected.
Posted Aug 21, 2025 - 21:34 UTC

Investigating

On some accounts Gift cards are not being created as expected, we are actively investigating the issue,
Posted Aug 21, 2025 - 20:57 UTC
This incident affected: Gift Cards.